Rohde & Schwarz FSIQ26 Reparatur.

Mein FSIQ26 von Rohde & Schwarz hatte in der letzten Zeit öfter das Problem, dass der Selbsttest mit der Fehlermeldung “2nd IF Converter” beendet wurde.

Dank des sehr ausgeklügelten System von Messpunkten innerhalb der neueren R&S Geräte war es möglich die Baugruppe und sogar die entsprechende Funktionsgruppe zu ermitteln die für den Fehler verantwortlich ist.

Für Jedes Modul innerhalb des FSIQ gibt es etliche Messpunkte, die über eine Service-Funktion abgerufen werden können. Meist sind dies Spannungen, die entsprechende Arbeitspunkte von Schaltungsteilen darstellen oder Eingangs/Ausgangspegel wiedergeben. In den Serviceunterlagen findet man hierzu die entsprechenden Soll-Werte und kann diese dann mit den selbst ermittelten Werten vergleichen.

Der Fehler zeigte sich im normalen Betrieb immer dann, wenn man ein Signal auf dem Analyzer mit einem SPAN größer 10 MHz betrachtet hat und dann den SPAN auf <= 10 MHz verringert hat. Dann verschwand das Signal plötzlich vom Bildschirm. Hat man den SPAN wieder auf > 10 MHz gestellt, war das Signal wieder da.

Wenn man sich das Konzept des FSIQ mit diesem Fehlerbild im Hinterkopf anschaut, dann fällt einem auf, dass ab einem SPAN von <= 10 MHz eine besondere Aufbereitung des Signals benutzt wird. Diese Aufbereitung übernimmt das Modul “Low Phase Noise” (Option B4), welches im FSIQ als Standard verbaut ist.

Jetzt klingeln wir mal die über eine Service-Funktion abrufbaren Testpunkte ab. Und siehe da … gleich der erste liefert einen Treffer. Der Testpunkt für den “Referenzfrequenz-Teiler” ist außer Toleranz. Und ein weiterer Messpunkt ist raus … “PLL Lockstatus” zeigt “unlocked” !! Das passt doch super zum Fehlerbild.

Zur Bestätigung der Annahme, dass es an der “Low Phase Noise” Einheit liegt, entnehme ich das Modul und ersetze es durch ein Reserve-Modul. Ich lasse den FSIQ extra abkühlen und starte ihn dann. Nach dem Bootvorgang starte ich den Selbsttest. Diesmal werde ich mit einem freundlichen “successfull” begrüßt. Auch eine “Full Calibration” endet erfolgreich.

Somit ist bestätigt dass der Fehler wirklich in der “Low Phase Noise” liegt.

Die Abfrage der Testpunkte ergab, dass der Teiler nicht richtig arbeitet. Also habe ich das Modul “Low Phase Noise” geöffnet und hier als Teiler auf dem Modul zweimal MC10E016 gefunden.

Ich habe jetzt bei der Fa. Mouser zwei der Teiler-ICs bestellt. Jetzt heißt es warten.

“Low Phase Noise” Option B4 geöffnet.

 

 

 

 

 

 

 

 

Nachdem nun meine Heissluft-Reworkstation eingetroffen ist, kann es nun bald ans Wechseln der beiden Teiler-ICs gehen.

Die Fa. Mouser hat nun auch die ICs geliefert und jetzt beginnen wir mit dem Tausch des ersten Teiler-ICs (mittig in der Baugruppe). Danach wird getestet ob das Modul wieder OK ist und falls nicht, wird ggf. das zweite IC getauscht.

Das IC ist nun gewechselt und die Tests können beginnen.

… wird fortgesetzt …

Getagged mit: , ,

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*