Rohde & Schwarz FSIQ26 Reparatur.

Mein FSIQ26 von Rohde & Schwarz hatte in der letzten Zeit öfter das Problem, dass der Selbsttest mit der Fehlermeldung “2nd IF Converter” beendet wurde.

Dank des sehr ausgeklügelten System von Messpunkten innerhalb der neueren R&S Geräte war es möglich die Baugruppe und sogar die entsprechende Funktionsgruppe zu ermitteln die für den Fehler verantwortlich ist.

Für Jedes Modul innerhalb des FSIQ gibt es etliche Messpunkte, die über eine Service-Funktion abgerufen werden können. Meist sind dies Spannungen, die entsprechende Arbeitspunkte von Schaltungsteilen darstellen oder Eingangs/Ausgangspegel wiedergeben. In den Serviceunterlagen findet man hierzu die entsprechenden Soll-Werte und kann diese dann mit den selbst ermittelten Werten vergleichen.

Der Fehler zeigte sich im normalen Betrieb immer dann, wenn man ein Signal auf dem Analyzer mit einem SPAN größer 10 MHz betrachtet hat und dann den SPAN auf <= 10 MHz verringert hat. Dann verschwand das Signal plötzlich vom Bildschirm. Hat man den SPAN wieder auf > 10 MHz gestellt, war das Signal wieder da.

Wenn man sich das Konzept des FSIQ mit diesem Fehlerbild im Hinterkopf anschaut, dann fällt einem auf, dass ab einem SPAN von <= 10 MHz eine besondere Aufbereitung des Signals benutzt wird. Diese Aufbereitung übernimmt das Modul “Low Phase Noise” (Option B4), welches im FSIQ als Standard verbaut ist.

Jetzt klingeln wir mal die über eine Service-Funktion abrufbaren Testpunkte ab. Und siehe da … gleich der erste liefert einen Treffer. Der Testpunkt für den “Referenzfrequenz-Teiler” ist außer Toleranz. Und ein weiterer Messpunkt ist raus … “PLL Lockstatus” zeigt “unlocked” !! Das passt doch super zum Fehlerbild.

Zur Bestätigung der Annahme, dass es an der “Low Phase Noise” Einheit liegt, entnehme ich das Modul und ersetze es durch ein Reserve-Modul. Ich lasse den FSIQ extra abkühlen und starte ihn dann. Nach dem Bootvorgang starte ich den Selbsttest. Diesmal werde ich mit einem freundlichen “successfull” begrüßt. Auch eine “Full Calibration” endet erfolgreich.

Somit ist bestätigt dass der Fehler wirklich in der “Low Phase Noise” liegt.

Die Abfrage der Testpunkte ergab, dass der Teiler nicht richtig arbeitet. Also habe ich das Modul “Low Phase Noise” geöffnet und hier als Teiler auf dem Modul zweimal MC10E016 gefunden.

Ich habe jetzt bei der Fa. Mouser zwei der Teiler-ICs bestellt. Jetzt heißt es warten.

“Low Phase Noise” Option B4 geöffnet.

 

 

 

 

 

 

 

 

Nachdem nun meine Heissluft-Reworkstation eingetroffen ist, kann es nun bald ans Wechseln der beiden Teiler-ICs gehen.

Die Fa. Mouser hat nun auch die ICs geliefert und jetzt beginnen wir mit dem Tausch des ersten Teiler-ICs (mittig in der Baugruppe). Danach wird getestet ob das Modul wieder OK ist und falls nicht, wird ggf. das zweite IC getauscht.

Das IC ist nun gewechselt und die Tests können beginnen.

… wird fortgesetzt …

10 Gedanken zu „Rohde & Schwarz FSIQ26 Reparatur.

  • 19. März 2019 um 20:43
    Permalink

    Lieber OM Stephan,
    ich habe eine Schwierigkeit mit meinem FSIQ26 bei dem ich sehr gern ihre Hilfe erbitte. Problem: Er verlangt beim Bootvorgang die Windows NT Startdiskette die ich aber nicht habe. So kann auch keine Fehleranalyse vom System gemacht werden. Hatten sie bei ihrem FSIQ26 Bootdisketten dabei und könnten sie mir diese gegen Kostenerstattung zur Verfügung stellen?

    Vy 73
    Wolfram Buchroth
    ex DG1OF (z.Zt. ohne Call)

    Antwort
    • 21. März 2019 um 8:46
      Permalink

      Hallo Wolfram,

      der FSIQ hat eine interne Festplatte und benötigt keine Diskette. Das bedeutet in deinem Fall wohl dass die interne Platte defekt ist oder ganz fehlt. Das bedeutet dann dass auch erst mal alle Lizenzen und Option Keys weg sind. Man kann die Platte von einem anderen FSIQ clonen, es bleibt dann aber das Problem, dass die Optionen nicht aktiviert werden können.

      Gruß
      Stefan

      Antwort
  • 19. März 2019 um 21:48
    Permalink

    Hallo OM Stefan,
    ich bin auch schon sehr viele Jahrzente ein Inthusiast für Messgeräte,wie du. Mir ist vor wenigen Tagen ein FSIQ 26 zugelaufen. Leider eben defekt. Die Fehleraufschrift im Display lautet “LO unlog”. Das Gerät ist von R&S unrepariert zurückgekommen, Reparaturkosten 6000,00€. Bemerkung: Reparatur der YIG Baugruppe. Frage: Hast du da Erfahrungen? Bekommt man noch ein Service Handbuch dafür? Wie groß sind meine Chancen einer erfolgreichen Reparatur?

    Auf eine Antwort von Dir würde ich mich sehr freuen.

    VY 73
    Peter, DG1CV / S04

    Antwort
    • 21. März 2019 um 8:47
      Permalink

      Hallo Peter,
      YIG Baugruppe ist immer böse … fragt sich nur wie böse.
      Kannst du mal genauer beschreiben wie das Fehlerbild ist ? Ist der YIG noch am leben ?

      Gruß
      Stefan

      Antwort
  • 7. November 2019 um 17:16
    Permalink

    Hallo Stefan,
    Dank deiner Unterstützung läuft mein FSIQ26 wieder zuverlässig. Der statische Yig-Abgleich war die Lösung für mein Problem.
    Zur Sicherheit wollte ich die Festplatte clonen. Leider ist der erste Versuch fehlgeschlagen, der FSIQ bootet nicht mehr. Vielleicht ist die verwendete Festplatte ungeeignet.
    Kannst du mir die Tastenkombination zum Start ins BIOS sagen? Oder hast du Hinweise für das Clonen der Festplatte? Ich will erst mal die alte Platte wieder einbauen und sehen, ob das Gerät wieder läuft.

    Gruß
    Peter, DG1VC

    Antwort
    • 8. November 2019 um 8:54
      Permalink

      Hallo Peter,

      ich benutze zum Clonen der Platten immer ClonZilla.

      Link zur Software: https://www.clonezilla.org/

      Du musst drauf achten, dass die Platte nicht zu groß ist. Es hat sich bewährt eine CF-Karte mit 32 GB zu nehmen und einen CF zu ATA Adapter.

      Es gibt auch ältere SSDs mit parallelem ATA Anschluß, evtl. findest du auch so etwas.

      Gruß

      Stefan Bode

      Antwort
      • 8. November 2019 um 15:09
        Permalink

        Hallo Stefan,

        vielen Dank für die schnelle Antwort. Ich werde dir und den anderen Usern schreiben, wenn es funktioniert hat.
        Gruß
        Peter

        Antwort
        • 19. November 2019 um 22:05
          Permalink

          Hallo Stefan,
          Ich habe eine 8 GB CF-Karte eingebaut. Der FSIQ26 läuft wie ein Rennpferd.
          Vielen Dank nochmals!

          73
          DG1VC

          Antwort
  • 25. Juni 2020 um 20:52
    Permalink

    Hallo Stefan,
    ich habe bei meinem FSEA30 genau dasselbe Problem mit dem fehlenden Signal bei span <= 10MHz…
    Hast du deinen FSIQ26 eigentlich repariert bekommen? Es gibt offensichtlich keine Fortsetzung dieses Reparaturthreads… Was war die genaue Ursache?

    Danke im Voraus,

    Walter

    Antwort
    • 26. Juni 2020 um 18:22
      Permalink

      Hallo Walter,

      Das Problem war ein defekter Teiler in der Baugruppe B4 (Low Phase Noise). Ich habe den Teiler getauscht und das Problem war behoben.

      Klapper mal die Diagnose für die B4 Option durch auch schaue ob iwo ein Wert ausserhalb der Norm ist.

      Gruß

      DL2OCB

      Antwort

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.